[Solved] mail: command not found on cPanel server

Hey! here is the solution for the below pasted error while you are trying to send emails by using a script.  You can simply fix this issue by installing the package mailx.

Error details:

mail: command not found

Solution:

yum install mailx
service postfix start
chkconfig postfix on

That’s it!

Post navigation

Arunlal A

Engineer. Linux enthusiast. Traveller. DevOps learner and practitioner. I enjoy working with Linux, DevOps, automation, and technology while exploring new places along the way. I use this space to share my experiences, learnings, experiments, and things I discover along the journey. Whether you're a seasoned DevOps professional or just getting started, let's connect, learn, and grow together. Happy coding, automating, and deploying!

One thought on “[Solved] mail: command not found on cPanel server”

  1. I’m getting a return of “Loaded plugins: versionlock” – “No package mailx available.” – “Error: Nothing to do” after running yum install mailx (as root)

Leave a Reply

Your email address will not be published. Required fields are marked *